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PRELUCRARI DE IMAGINI CU IMAGE-PRO PLUS  
(LUCRARE PRACTICA DE INITIERE) 

INTRODUCERE 
In aceasta sedinta de initiere in prelucrarea imaginilor vom introduce cateva 
din procedurile de baza utilizate in image processing (pe fondul 
cunostintelor teoretice prezentate la curs) si vom utiliza o versiune demo a 
programului Image-Pro Plus (IPP) v. 3.0 (Registered trademark of Media 
Cybernetics, L.P.). Lucrarea practica va consta si intr-o initiere in utilizarea 
programului IPP, precum si a procedurilor sale de baza. 

APLICATIA Image-Pro Plus 
Image-Pro Plus este o aplicatie Windows – deci se deschide utilizand 
butonul START→Image-Pro Plus 3.0→Image-Pro Plus. 
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 Ca si in cazul celorlalte aplicatii Windows, fereastra aplicatiei IPP 
are: o bara de titlu, o bara de meniu (Menu Bar), o bara de unelte (Tool 
Bar), etc. – puteti identifica toate elementele in figura de pe pagina 
anterioara, ele avand un comportament similar cu cele din alte aplicatii 
Windows. 

IMBUNATATIREA UNEI IMAGINI 

1. Incarcarea unei imagini 
Selectati File→Open… din meniu si incarcati fisierul Bankvid.tif din 
folder-ul C:\ipwin3\images (in mod normal, folder-ul implicit). 
 TIFF in campul Files of type indica faptul ca aceasta imagine este de 
tipul Tagged Image File Format. 

 Fisierul incarcat contine o imagine cam neclara luata cu o camera de 
supraveghere dintr-o banca si are in prim-plan un posibil suspect. Vom 
incerca sa imbunatatim calitatea imaginii, astfel incat trasaturile acestuia sa 
devina mai clare. Vom aduce modificari pe o copie de lucru, lasand 
imaginea initiala nealterata – pentru a crea imaginea de lucru, utilizam 
optiunea Edit→Duplicate/Crop din meniu. 

2. Reglarea parametrilor de contrast 
Selectati Process→Contrast Enhancement… din meniu sau utilizati butonul 

 pentru a afisa fereastra-dialog de reglare a prametrilor (imaginea din 
stanga). 
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 Mariti valorile pentru Brightness (53), Contrast (63) si Gamma (1.2) 
si observati cum imaginea se schimba. 
 Mentionam ca aceste ajustari NU sunt permanente – cand considerati 
ca imaginea arata bine, apasati butonul Apply pentru ca ele sa devina 
permanente (operatie care se face cu confirmare – imaginea din dreapta). 
Observati ca, dupa aceasta salvare, cele trei cursoare (Brightness, Contrast, 
si Gamma) se reintorc la pozitiile initiale. 

3. Filtrarea imaginii 
Pentru a imbunatati imaginea in continuare, vom utiliza o filtrare de intarire 
a detaliilor. Selectati Process→Filters… din meniu sau butonul  pentru a 
deschide fereastra de dialog a comenzii de filtrare si alegeti optiunea 
Enhancement – observati detaliile in figura. 

 

 Apasand butonul Apply, filtrul ales va fi aplicat pe imagine – 
observati efectele. 

4. Definirea unei zone de interes pe imagine 
In aceasta etapa de prelucrare, vom defini o zona de interes – Area of 
Interest (AOI) - in jurul suspectului si vom compara aceasta zona din 
imagine cu originalul. 
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 Pentru a defini o zona de intres dreptunghiulara, vom apasa butonul 

 si vom selecta zona AOI asa cum se vede in figura (utilizand mouse-ul). 

 

 Marim zona AOI selectand Edit→Resize… din meniu si alegand un 
procent de 300% (aveti grija ca sa fie casuta Allow Distorsion pusa Off). 

 Activati fereastra imaginii initiale Bankvid.tiff (click in fereastra) si 
faceti click pe butonul de Zoom  din bara de unelte. Pozitionati apoi lupa 
deasupra suspectului si utilizati butonul din stanga al mouse-ului pentru 
marire (cu acelasi ordin de marime ca si in imaginea prelucrata). 

 Plasati imaginea originala (Bankvid.tiff) si imaginea prelucrata 
(Untitled1) una langa alta pentru a le putea compara, ca in figura. 
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ANALIZA SI FILTRAREA UNEI IMAGINI 

1. Incarcarea unei imagini 
Incarcati imaginea leu.jpg din folder-ul C:\ipwin3\images (similar ca 
situatia anterioara, cu optiunea All Formats in campul Files of type). 
Extensia JPG indica formatul fisierului – standardul JPEG (Joint 
Photographic Experts Group). 

 Utilizati optiunea Measure→Bitmap Analysis… din meniu pentru a 
vedea matricea-imagine. Observati dimensiunile imaginii, afisate si pe linia 
de stare (Width=287 pixels, Height=260 pixels) si numarul de nivele de gri 
(256). 

2. Histograma unei imagini 

Selectati Measure→Histogram… din meniu sau utilizati butonul  pentru 
a afisa histograma imaginii. Setati optiunile din fereastra asa cum sunt 
aratate in figura si observati cele doua linii verticale utilizate pentru 
marcarea unui domeniu de interes pentru valorile de gri (ele pot fi 
pozitionate cu ajutorul mouse-ului). 

 

 Utilizati optiunea Edit→Rotate din meniu pentru a roti imaginea (ce 
unghi doriti) – o noua fereastra imagine este deschisa. Vizualizati 
histograma acesteia si comparati-o cu cea a imaginii originale. 
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 Utilizati Edit→Duplicate/Crop pentru a obtine o noua fereastra 
imagine cu o copie de lucru si creati negativul acesteia, utilizand optiunea 
Process→Invert Image din meniu. Explicati rezultatul obtinut. 

 Pe imaginea originala (sau pe o copie), utilizati optiunea 
Process→Color Segmentation din meniu sau butonul  si incercati sa 
definiti doua sau trei clase de nivele de gri si sa observati cum sunt 
distribuite valorile de gri pe imaginea analizata. Utilizati liniile verticale de 
delimitare a claselor de valori de gri, asa ca in imagine. 

 

3. Operatii aritmetice si logice pe imagini 
Incarcati imaginea circuit.tiff din folder-ul C:\ipwin3\images si afisati-i 
histograma. Pentru incarcarea imaginii puteti utiliza maniera obisnuita 
(File→Open…) sau baza de imagini a IPP – fie selectati File→Image 
Database… din meniu, fie butonul  de pe bara de unelte. 

 Utilizati optiunea Process→Operations… din meniu sau butonul  
pentru a aduna cele doua imagini (leu + circuit), setand parametrii asa cum 
este aratat in figura. 
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 Afisati histograma imaginii rezultate. Este histograma noii imagini 
suma histogramelor imaginilor de la care ati pornit? Incercati sa gasiti o 
explicatie. 

 Incercati sa aplicati si alte operatii aritmetice si/sau logice pe cele 
doua imagini, precum si pe alte imagini. 

4. Filtrarea imaginilor 
Incarcati doua imagini cu zgomot din acelasi folder C:\ipwin3\images 

 leu-zg.jpg – cu zgomot distribuit uniform in plaja 0÷255 
 leu-s&p.jpg – cu zgomot binar (“sare si piper”) 

 Utilizati optiunea Process→Filters din meniu sau butonul  pentru 
a filtra zgomotul din cele doua imagini, ca in figura. Este indicat sa utilizati 
copii de lucru ale imaginilor, in asa fel incat sa le pastrati pe cele originale 
ca referinte. 

 Incercati filtrele LoPass, Gauss, Median cu diferite optiuni privind 
vecinatatea considerata, sa si numarul de treceri si “taria” modificarii. 



Prelucrari de imagini cu Image-Pro Plus (initiere) 
 

 142 

 

 Utilizati apoi optiunea Kernels din fereastra comenzii Filters pentru 
a vedea coeficientii filtrelor de convolutie – utilizati butonul Edit pentru a 
putea vizualiza acesti coeficienti, asa ca in figura. 
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 Incercati sa definiti propriile voastre filtre si verificati-va asteptarile 
in ceea ce priveste modificarile facute pe imagini atunci cand le aplicati. 

NUMARAREA, MASURAREA SI CLASIFICAREA OBIECTELOR 
DIN IMAGINI 
Obiect este considerat orice grup contiguu de pixeli care au valorile de 
intensitate intr-un anumit domeniu specificat. Cu comanda Count/Size, 
aceste obiecte pot fi extrase, numarate si masurate intr-o multime de 
modalitati, asa cum vom vedea in continuare. 

1. Incarcarea imaginii 
Incarcati imaginea exm50x.tif din folder-ul C:\ipwin3\images. 

2. Segmentarea imaginii 

Utilizati optiunea Measure→Count/Size… din meniu sau butonul  din 
bara de unelte. Selectati apoi optiunea Manual pentru Intensity Range 
Selection (ca in figura stanga) si apasati butonul Select Ranges – apare 
fereastra de dialog Segmentation (figura dreapta). “Segmentarea” imaginii 
se refera la extragerea “obiectelor” din imagine. 

   

 Alegeti optiunea Histogram Based si setati limitele pentru Class 1 
intre 182 si 255, pentru a selecta obiectele de culoare deschisa, asa ca in 
figura (setarea o puteti face fie pozitionand liniile verticale de marcare, fie 
schimband valorile numerice din casutele respective). 
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3. Masurarea si numararea obiectelor 
In fereastra Count/Size, alegeti optiunea Measure→Select Measurements… 
din meniu – observati noua fereastra de dialog care se deschide in figura. 

 
 Adaugati (simplu click cu mouse-ul) masuratorile care sunt relevante 
pentru imaginea analizata: Area (existenta implicit), Hole Area, Hole Ratio 
si Holes (observati explicatiile privind semnificatia acestor parametri din 
partea sus dreapta in fereastra Select Measurements). 

 Apasati butonul Count in fereastra comenzii Count/Size – imaginea 
este analizata, obiectele de culoare deschisa sunt extrase, numarate si 
masurate. Contururile obiectelor si etichetele apar in fereastra imagine. 

 Apasati butonul Options… in fereastra comenzii Count/Size – in 
fereastra de dialog care se deschide, selectati optiunea With Holes din lista 
Outline Style, asa ca in figura – aceasta optiune conduce la conturarea 
obiectelor atat in exterior, cat si in jurul gaurilor din acestea. 
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 Daca faceti dublu click pe oricare dintre obiecte, se deschide o 
fereastra care afiseaza atributele obiectului respectiv, asa ca in figura de mai 
jos. 

 

4. Divizarea obiectelor 
Daca examinati imaginea, veti constata ca obiectul #61 provine de fapt din 
doua granule alaturate, in fapt obiecte distincte. 

 Pentru a remedia aceasta greseala si a diviza obiectul in cele doua 
componente reale, utilizati optiunea Edit→Split Objects… din fereastra 
comenzii Count/Size, asa ca in figura. 
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 Utilizand mouse-ul, trasati o linie de divizare, asa ca in figura din 
stanga (urmati indicatiile date de IPP). Aveti grija ca, atunci cand faceti 
click cu mouse-ul, cursorul sa nu atinga obiectul sectionat. Cand apasati 
butonul OK, IPP reanalizeaza imaginea si divizeaza obiectul #61 in cele 
doua granule componente, numerotate #61 si #64 (figura dreapta). 

    

5. Clasificarea obiectelor 
In fereastra comenzii Count/Size, selectati optiunea Measure→Single 
Variable Class, iar in fereastra de dialog Classification care apare, selectati 
Hole Ratio din lista, asa ca in figura (dorim sa clasificam obiectele dupa 
raportul arie efectiva/arie totala). 
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 Number of Bins indica numarul de sub-intervale pentru domeniul 
Hole Ratio (intre valoarea minima si cea maxima). Cu un click pe butonul 
OK, apare fereastra cu datele clasificate (figura). 

 
 In fereastra comenzii Count/Size, selectati optiunea 
View→Measurement Data, iar din lista alegeti Sort Down pentru a obtine 
ordine descrescatoare (figura). 

 
 In fereastra comenzii Count/Size, apasati butonul Options…, iar in 
fereastra de dialog care apare selectati optiunea Class in lista Label Style, 
asa ca in figura (pentru a eticheta obiectele functie de clasa careia ii apartin). 
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6. Salvarea datelor obtinute in urma clasificarii 
In fereastra de dialog Measurement Data, selectati optiunea File→Data to 
File pentru a salva datele intr-un fisier Excel – setati toate informatiile 
corespunzator pentru acest export de date (asa ca in figura), cu grija 
deosebita pentru folder-ul de destinatie daca lucrati in retea (caseta Save 
in:). 

 
 Verificati apoi daca datele au fost salvate corect (deschideti fisierul 
Excel tocmai creat). 
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INCHEIEREA SESIUNII DE LUCRU 
Inchiderea aplicatiei IPP se face in mod similar cu toate celelalte aplicatii 
Windows cunoscute. 

IN ACEASTA SEDINTA DE LUCRARI PRACTICE ATI INVATAT 
 sa incarcati un fisier imagine si sa creati copii de lucru 

 sa ajustati parametrii de contrast 

 sa definiti o zona de interes pe imagine 

 sa imbunatatiti calitatea unei imagini aplicand diverse filtre 

 sa vizualizati histograma unei imagini si sa o interpretati 

 sa faceti operatii aritmetice si logice cu imagini 

 sa faceti segmentarea unei imagini pe baza histogramei 

 sa numarati obiectele dintr-o imagine si sa masurati anumiti parametri 

caracteristici pentru acestea 

 sa divizati obiecte, atunci cand este nevoie de corectii manuale 

 sa exportati date statistice intr-un program de tip spreadsheet (Excel) 

 


